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SketchUp Instructions  
 

Every architect needs to know how to use SketchUp! 
 
SketchUp is free from Google just Google it and download to your computer. You can 
do just about anything with it, but it is especially good for conceptualization of 
architectural design. The current version (November, 2010) is 8.0. These instructions 
are based on this version. There is also a professional version, SketchUp Pro 8.0, that 
they sell online for $495.00. Students can purchase a one year license of SketchUp Pro 
for $49.00. But I would recommend downloading the free version from Google.  
 
The major difference between free and Pro version is the ability of SketchUp Pro to 
import from and export into AutoCAD. If you really want to import AutoCAD drawings, 
you could download the SketchUp Pro version for an 8 hour trial, import the AutoCAD 
drawing, and just not follow through with your purchase. The earlier version, SketchUp 
7.1, allows for using a free AutoCAD import plugin that you can download from the 
Google SketchUp site. However, in order to import an AutoCAD drawing into SketchUp 
7.1, you need to first save the AutoCAD drawing down to AutoCAD 2007. The AutoCAD 
drawing will import into SketchUp as a Group, which can then be exploded down to 
individual elements, which, in turn, must also be exploded to be able to change them in 
SketchUp. It is kind of a mess. It’s really better just to redraw the drawing in SketchUp. 
 
There are some great video tutorials online on the Google SketchUp web site. There is 
also an extensive online library of SketchUp premade components which are available 
directly within the program. SketchUp also plays well with Google Earth allowing you to 
not only design a building but place it on its actual site anywhere on the earth. 
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1. Open SketchUp 

 
2. If the screen is not set as shown below, make the following changes: 

 

 
 

a. Turn on the “Large Tool Set” Toolbar: Select the View  pulldown menu 
>Toolbars>Large Tool Set  
 

b. Turn on the “Views” Toolbar: Select the View  pulldown menu 
>Toolbars>Views 
 

c. Turn on the “Shadows” Toolbar: Select the View  pulldown menu 
>Toolbars>Shadows 
 

d. Turn on the “Styles” Toolbar: Select the View  pulldown menu 
>Toolbars>Styles 
 
 

e. Turn off perspective view for the start of the project: select Camera 
pulldown> Parallel Projection 
 

3. Go to the plan view by clicking on the Plan icon:  
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4. Your screen will look like this: 
 

 
 
 

5. Draw a line: Use the pencil tool 
 

   
 

6. You can draw in X (red) or Y (green) or Z (blue) direction.  If you want to make 
the line exactly 20’-6” long, pick the start point, then point the cursor in the 
direction you want to the end point to be located then type in 20’6 on the 
keyboard. Inputting distances for lines is the same as AutoCAD: click a point, 
then point the cursor in the direction you want to draw the line, then type the 
distance.  

 
7. Note that the native units of SketchUp are inches, just like AutoCAD, in other 

words, if you type a distance of 100 and do not put the foot symbol after it (’) it 
will be interpreted by SketchUp as 100 inches. If you mean feet, type the foot 
mark (’). To separate fractions of an inch from whole inches, leave a space. 
 

8. At any time while you are drawing an entity, for example, a line or rectangle, you 
can type the dimensions in the "VCB" box and the entity will be drawn to those 
dimensions.  
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a. If you want to draw a line that is 9 feet 6 inches long, start to draw the line 
in the direction you want, then type: 9' 6" (you don't need to click in the 
"VCB" box in order to type in it, just start typing), and then press Enter.  
 

b. If you want to draw a rectangle that is 6 feet 6 inches wide by 4 feet 6 
inches deep, begin to draw the rectangle, type: 6' 6", 4' 6" (again, you 
don't need to type in the "VCB" box), and then press Enter.  
 

9. As you draw lines when a start or end point of the line aligns with another point, 
SketchUp will signal graphically by drawing a red, green or blue line from point to 
point – like the illustration below:  

 

 
 

14. Draw a plane 
 

 Draw a rectangle 
 Change to a 3d view: select the isometric icon: 

 

   
 
 
 

 The drawing will look like this: 
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 Select the Push-Pull tool: 
 

 
 

 Click the left mouse button on the top face and pull it up. If you want to be 
precise about the distance, type a number (add the foot mark if you mean 
feet). 

 

 
 

 Turn on shadows: 
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 Note that you can set the month of the year and the time of day for setting 
the sun direction. 

 

 
 

 You can change the color of any modeled surface. To do that, select the 
Paint Bucket: 
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 The Materials dialogue box will appear. 
 

 
 

 Select “Colors” from the pull-down list: 
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 Make sure that “Shaded” button is turned on: 

 

 
 
 
 
 

 Select a color from the color palette and pick a plane that you want to 
color: 

 

 
 
 

 If you turn the X-Ray icon on, also, you can see into the object: 
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 Other ways of viewing your objects are “Wireframe,” “Hidden Line,” and 
“Shaded.” 

 
 

19. To move, rotate or scale an object, first select the whole object using the select 
tool . You can pick one part at a time or select with a window or a crossing 
window. If you want to select several parts one at a time, hold down the shift key. 
To unselect an a part of object that has been selected, hold the shift key down 
and reselect it. If you want to cancel the selection, just right click the mouse on a 
blank area of the drawing. 

 
 

         
 

20. Then pick the “Move” or “Rotate” or “Scale” tool: 
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21. To lengthen a line, click on the Move tool, click on the end of the line you want to 
lengthen (there will be a green grip appear) and move it to a new location. 
 

22. To copy an object, use the Move tool, but hold down the Ctrl key while moving. 
 

23. To mirror, select the objects, right click and pick “Flip Along” then select red, 
green or blue direction. You cannot mirror along a diagonal axis, so you have to 
mirror first then rotate the object. If you want to mirror an object and keep the 
original, make a copy of it first. 

 
24. Saving: pick the Save icon or select File and then Save. The first time you save 

you will be prompted for a name for the file as well as a location in which to save 
it. 

 
25. How to draw a building with a gable roof. 

 
 Draw a rectangle 
 Extrude it vertically 
 Draw a line down midpoint of one top edge to the other 
 Use the Move command to drag that line vertically (along the blue axis) 

 
26. How to draw a building with a hip roof 

 Draw a rectangle 
 Extrude it vertically 
 Draw a line down midpoint of one top edge to the other 
 

 
 

Draw a square from one corner to the line 
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Draw the diagonal of the square (45 degrees) 
 

 
 

Draw the other diagonal (45 degrees) 
 

\ 
 

Erase the square 
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Repeat on the other side 
 

 
 

Grab the top ridge with the Move tool and move up (along the Blue axis) 
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Bob’s your Uncle 
 

27. How to create Multiple Copies (Linear Arrays)  
 

 The Move Tool can be used to create arrays, or a series of copies of 
geometry.  

 To create multiple copies of one or more entities: Select the “Select” Tool. 
The cursor will change to an arrow.  

 Select the entities to be copied. 
 Select the “Move” Tool.  
 Press and hold the Ctrl key on your keyboard. This action informs 

SketchUp that you want to duplicate the selected entities. 
 Click on the selected entities to copy.  
 Move your mouse to copy the entities. A copy of the selected entities will 

follow as you move your mouse. 
 Click at the destination point to finish your copy operation. The copied 

entities are now selected and the original entities are deselected.  
 Type a multiplier value to create additional multiple copies. For example, 

typing in 2x (or *2) will create one additional copy (or 2 copies total, the 
one you manually copied plus one you automatically copied using this 
step) instead of just one. 

 
28. How to draw roads: 

 Start with a large rectangle, which will be the ground plane 
 Draw lines on it 25’ apart. 
 Connect the corners 
 Draw an arc at each intersection 
 Erase the excess 
 Make closed at ends to turn into a plane 
 Extrude 3’ vertically down. (I know this is too large of a curb height, but we 

want to make a visible depth to the road). 
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29. How to use the "Follow Me" Tool 
 

Draw a rectangle 30’ in the X direction and 40’ in the Y direction.  
 

 
 

Pull it up 6’                                                                                
 
 

 
 

Draw a line 6” up and 12” to right to form the first riser and tread. 
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Copy these two lines by selecting them first, then select the move command, and 
pick the first point as the bottom of the riser, the press and hold the control key down 
and pick the right end of the horizontal line, then type x11. This will array the steps 
11 times. 

 

 
 

Note that the top portion of the cube can now be pushed and pulled separately from 
the bottom. That is required to use the FollowMe tool.  
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Select the FollowMe tool. 
 
Place the cursor over the top part of the cube above the steps and click with left 
button. 
 
Place the cursor and follow it along the top edge of the cube – you will see the edge 
line turn red.  
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Follow all along the left and far edge:  

 

 
 

This is the result: 
 

 
 

You could follow it all the way around if you had enough width to do stairs all around.  
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Pretty cool – this takes some practice. So go ahead, practice! 
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Below is an explanation of the tools: 
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30. Shading and view commands: 

 
 
 

31. SketchUp and Google earth 

You can place a SketchUp model anywhere on the earth using Google Earth.  
Here is how: 

Open SketchUp 

Draw a model in SketchUp 

Import the site from Google Maps by selecting the icon in the SketchUp menu bar with 
the yellow arrow pointing down.  

 

 

An “Add Location” Dialogue box will appear: 
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Type in the address of the location you want, and then click on “Select Region” button. 
You can then adjust the pins at the corners and, then select the “Grab” button. 
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If you don't like the background, click on it so the border turns red, then right click and 
select "unlock" from the context cursor menu. The border will then turn blue. Now select 
the delete key on the keyboard.  
 
Here is the original 3d image in Google Earth: 
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Below is the image SketchUp after importing the Google Earth site to SketchUp: 

 

 

You can move, rotate or scale your drawing on the Google Maps background, but you 
will not be able to change the background. After you have the building where you want 
it, and want to see how it will look in Google Earth in 3d, export it along with the site to 
Google Earth by selecting the "Place Model" icon in the SketchUp menu bar with the 
orange arrow pointing up.  
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Now here is how your "placed" model will look in 3d in Google Earth: 

 

Note that you can continue to make changes to the model in SketchUp and then use 
"Place Model" again to update it. 

 

 

Answer “Yes” to update the image in Google Earth.  

Note that you cannot cast shadows in Google Earth. 
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32. SketchUP animations and Power Point 
 

a. Open SketchUp and make a drawing 
b. Create Scenes in SketchUp by selecting View>Animation>Add Scene 
c. Zoom, move viewpoint, add color, change time of day or add to model in 

some other way and add another scene. 
d. After you have added all the scenes you want for your animation, select 
e. File>Export>Animation. Give it a name and a path to save. It will save your 

file as an .avi file. 
f. Open Power Point and make a new show. 
g. Click on the Insert tab>Movie. Browse to the avi file you just created and 

select it. In the Microsoft Office Power Point dialogue box that pops up "How 
do you want the movie to start in the slide show," select the button 
"Automatically." 
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Frequently Asked Questions 

Question 1:  Why is my model being clipped and sliced as I rotate or zoom in?  

1. This is a known glitch in the software called Camera Clipping Plane. First, don't 
worry; although it can be distracting, this doesn't cause any actual damage to 
your model. 

2. There are several situations in which you might encounter this: 
3. One is when the field of view (FOV) is set very wide. You can adjust the FOV 

between 1 and 120 degrees (the default is 35 degrees in Google). It's easy to 
unintentionally change the FOV by pressing the Shift key while you are zooming 
in or out using the Zoom tool. 

4. Another situation that can cause clipping is when the Perspective camera mode 
is turned off. In that case, click the "Zoom Extents" button (it looks like a 
magnifying glass with four red arrows pointing outward). The camera zooms out 
to display the entire model, and the clipping is eliminated. 

 

5. A third situation is when the scale of your model is very small or very large. In 
this case, you can change the scale of your model.  

6. This can also happen if your model is very far away from the origin point (the 
point where the red, green, and blue axes intersect). In that case, you can move 
your model closer to the origin point. To do this: select all of the geometry in your 
model, use the Move tool to grab a corner point of the selected geometry that is 
on the ground plane, start to move the selected geometry, and then type "[0,0,0]" 
(including the square brackets) in the "Value Control Box" (which is in the lower-
right corner of the SketchUp window). This causes the selected point to be 
moved to the origin point.  

7. I have found that the easiest way to fix it is to simply Zoom Extents  
(Camera, Zoom-Extents, or Ctrl-Shift-E) 
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Question 2: How do I Change the scale of an entire model? 

1. If you have drawn a model composed of many entities, for example, an entire 
house made of many edges, faces, and other entities, and then want to change 
the scale of the entire model, there's an easy way to do this: 

2. Pick an individual entity that you can use as a reference, for example, an edge 
that is about six feet long, but that you know you want to be exactly nine feet 
long.  

3. Select the Tape Measure tool and measure that edge from beginning to end. You 
should see 6' displayed in the "VCB."  

4. Type the length you want the edge to be, 9', and then press Enter.  
5. A message asks, "Do you want to resize the model?" Click "Yes" to resize the 

entire model.  

 
 


